Back to top

Game of Thrones Season 7 Finale May Leak Online

Posted By:Matt McGloin
Sat, 08/19/2017 - 21:02

Two Game of Thrones episodes have already been released online early, and now it's being reported the Game of Thrones Season 7 finale may leak online early.

While the Game of Thrones leaks of episodes four and six are said to be not a result of the hack - an HBO affiliate in India leaked episode four, and reportedly HBO Spain aired episode six early - the hackers have sent a batch of documents containing the passwords of all the HBO social networks to Mashable as proof of their intent.

"Be ready for GOT S& E6 &E7 as soon as possible," the group warned. 

The previous Game of Thrones episode leaks haven't hurt the ratings, so it remains to be seen if HBO will actually try and do anything to prevent the leak, such as pay a BitCoin ransom. The ratings for each episode this season have broken records, so there may be no need to even bother. We could also probably argue the hacks and leaks have only increased hype for Game of Thrones this season, especially - ironically enough - on social networks, so it's probable that HBO will just weather the storm, though I believe HBO is working with law enforcement.

You can actually go on social networks such as Facebook, Reddit and Twitter where users claim they have watched the Game of Thrones leaked episodes, and they state it only makes them want to watch the episode in HD even more when it officially airs on HBO because they are that good.

While the leaks of HBO episodes and passwords for social network may be alarming, what is more alarming is that the hackers leaked the addresses of actors. We don't need crazy fans going to the actors houses or calling them on the phone. 

I haven't read anywhere online why the hackers event went after HBO in the first place other than "they can"--because obviously there is a flaw in HBO's security, but WB and HBO need to cough up some dough to protect their online presence and servers. 

COMMENTS:

Subscribe To Cosmic Book News

* indicates required